Kconfig 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216
  1. # SPDX-License-Identifier: GPL-2.0-only
  2. config NFS_FS
  3. tristate "NFS client support"
  4. depends on INET && FILE_LOCKING && MULTIUSER
  5. select CRC32
  6. select LOCKD
  7. select SUNRPC
  8. select NFS_COMMON
  9. select NFS_ACL_SUPPORT if NFS_V3_ACL
  10. help
  11. Choose Y here if you want to access files residing on other
  12. computers using Sun's Network File System protocol. To compile
  13. this file system support as a module, choose M here: the module
  14. will be called nfs.
  15. To mount file systems exported by NFS servers, you also need to
  16. install the user space mount.nfs command which can be found in
  17. the Linux nfs-utils package, available from http://linux-nfs.org/.
  18. Information about using the mount command is available in the
  19. mount(8) man page. More detail about the Linux NFS client
  20. implementation is available via the nfs(5) man page.
  21. Below you can choose which versions of the NFS protocol are
  22. available in the kernel to mount NFS servers. Support for NFS
  23. version 2 (RFC 1094) is always available when NFS_FS is selected.
  24. To configure a system which mounts its root file system via NFS
  25. at boot time, say Y here, select "Kernel level IP
  26. autoconfiguration" in the NETWORK menu, and select "Root file
  27. system on NFS" below. You cannot compile this file system as a
  28. module in this case.
  29. If unsure, say N.
  30. config NFS_V2
  31. tristate "NFS client support for NFS version 2"
  32. depends on NFS_FS
  33. default n
  34. help
  35. This option enables support for version 2 of the NFS protocol
  36. (RFC 1094) in the kernel's NFS client.
  37. If unsure, say N.
  38. config NFS_V3
  39. tristate "NFS client support for NFS version 3"
  40. depends on NFS_FS
  41. default y
  42. help
  43. This option enables support for version 3 of the NFS protocol
  44. (RFC 1813) in the kernel's NFS client.
  45. If unsure, say Y.
  46. config NFS_V3_ACL
  47. bool "NFS client support for the NFSv3 ACL protocol extension"
  48. depends on NFS_V3
  49. help
  50. Some NFS servers support an auxiliary NFSv3 ACL protocol that
  51. Sun added to Solaris but never became an official part of the
  52. NFS version 3 protocol. This protocol extension allows
  53. applications on NFS clients to manipulate POSIX Access Control
  54. Lists on files residing on NFS servers. NFS servers enforce
  55. ACLs on local files whether this protocol is available or not.
  56. Choose Y here if your NFS server supports the Solaris NFSv3 ACL
  57. protocol extension and you want your NFS client to allow
  58. applications to access and modify ACLs on files on the server.
  59. Most NFS servers don't support the Solaris NFSv3 ACL protocol
  60. extension. You can choose N here or specify the "noacl" mount
  61. option to prevent your NFS client from trying to use the NFSv3
  62. ACL protocol.
  63. If unsure, say N.
  64. config NFS_V4
  65. tristate "NFS client support for NFS version 4"
  66. depends on NFS_FS
  67. select KEYS
  68. help
  69. This option enables support for version 4 of the NFS protocol
  70. (RFC 3530) in the kernel's NFS client.
  71. To mount NFS servers using NFSv4, you also need to install user
  72. space programs which can be found in the Linux nfs-utils package,
  73. available from http://linux-nfs.org/.
  74. If unsure, say Y.
  75. config NFS_SWAP
  76. bool "Provide swap over NFS support"
  77. default n
  78. depends on NFS_FS && SWAP
  79. select SUNRPC_SWAP
  80. help
  81. This option enables swapon to work on files located on NFS mounts.
  82. config NFS_V4_1
  83. bool "NFS client support for NFSv4.1"
  84. depends on NFS_V4
  85. select SUNRPC_BACKCHANNEL
  86. help
  87. This option enables support for minor version 1 of the NFSv4 protocol
  88. (RFC 5661) in the kernel's NFS client.
  89. If unsure, say N.
  90. config NFS_V4_2
  91. bool "NFS client support for NFSv4.2"
  92. depends on NFS_V4_1
  93. help
  94. This option enables support for minor version 2 of the NFSv4 protocol
  95. in the kernel's NFS client.
  96. If unsure, say N.
  97. config PNFS_FILE_LAYOUT
  98. tristate
  99. depends on NFS_V4_1
  100. default NFS_V4
  101. config PNFS_BLOCK
  102. tristate
  103. depends on NFS_V4_1 && BLK_DEV_DM
  104. default NFS_V4
  105. config PNFS_FLEXFILE_LAYOUT
  106. tristate
  107. depends on NFS_V4_1
  108. default NFS_V4
  109. config NFS_V4_1_IMPLEMENTATION_ID_DOMAIN
  110. string "NFSv4.1 Implementation ID Domain"
  111. depends on NFS_V4_1
  112. default "kernel.org"
  113. help
  114. This option defines the domain portion of the implementation ID that
  115. may be sent in the NFS exchange_id operation. The value must be in
  116. the format of a DNS domain name and should be set to the DNS domain
  117. name of the distribution.
  118. If the NFS client is unchanged from the upstream kernel, this
  119. option should be set to the default "kernel.org".
  120. config NFS_V4_1_MIGRATION
  121. bool "NFSv4.1 client support for migration"
  122. depends on NFS_V4_1
  123. default n
  124. help
  125. This option makes the NFS client advertise to NFSv4.1 servers that
  126. it can support NFSv4 migration.
  127. The NFSv4.1 pieces of the Linux NFSv4 migration implementation are
  128. still experimental. If you are not an NFSv4 developer, say N here.
  129. config NFS_V4_SECURITY_LABEL
  130. bool
  131. depends on NFS_V4_2 && SECURITY
  132. default y
  133. config ROOT_NFS
  134. bool "Root file system on NFS"
  135. depends on NFS_FS=y && IP_PNP
  136. help
  137. If you want your system to mount its root file system via NFS,
  138. choose Y here. This is common practice for managing systems
  139. without local permanent storage. For details, read
  140. <file:Documentation/admin-guide/nfs/nfsroot.rst>.
  141. Most people say N here.
  142. config NFS_FSCACHE
  143. bool "Provide NFS client caching support"
  144. depends on NFS_FS
  145. select NETFS_SUPPORT
  146. select FSCACHE
  147. help
  148. Say Y here if you want NFS data to be cached locally on disc through
  149. the general filesystem cache manager
  150. config NFS_USE_LEGACY_DNS
  151. bool "Use the legacy NFS DNS resolver"
  152. depends on NFS_V4
  153. help
  154. The kernel now provides a method for translating a host name into an
  155. IP address. Select Y here if you would rather use your own DNS
  156. resolver script.
  157. If unsure, say N
  158. config NFS_USE_KERNEL_DNS
  159. bool
  160. depends on NFS_V4 && !NFS_USE_LEGACY_DNS
  161. select DNS_RESOLVER
  162. default y
  163. config NFS_DEBUG
  164. bool
  165. depends on NFS_FS && SUNRPC_DEBUG
  166. default y
  167. config NFS_DISABLE_UDP_SUPPORT
  168. bool "NFS: Disable NFS UDP protocol support"
  169. depends on NFS_FS
  170. default y
  171. help
  172. Choose Y here to disable the use of NFS over UDP. NFS over UDP
  173. on modern networks (1Gb+) can lead to data corruption caused by
  174. fragmentation during high loads.
  175. config NFS_V4_2_READ_PLUS
  176. bool "NFS: Enable support for the NFSv4.2 READ_PLUS operation"
  177. depends on NFS_V4_2
  178. default y
  179. help
  180. Choose Y here to enable use of the NFS v4.2 READ_PLUS operation.